1. Invitado La navidad llego a Cz, ¿Por que no vas a visitar la choza de Santa Cooz?
  2. Invitado ¿Puedes jugar sin repetir palabra?
    Descartar aviso
  3. Invitado ¿Por que no derribas a un que otro adversario con una bola de nieve?
    Descartar aviso
  4. Invitado Faltando tan solo unas pocas horas para navidad, alguien a quien no le gusta esta festividad, decidió sorprender a santa, raptarlo, atarlo y robar los regalos que llevaba consigo.
    Descartar aviso
  5. Invitado Esta vez el grinch esta en CemZoo y quiere tener su propio arbol para ponerlo en su casa pero no quiere cualquiera, tiene que ser creativo y unico el cual escogerá.
    Descartar aviso

Solucionado Packet Tracer: Aprendiendo mientras intento enseñar

Tema en 'Asistencia CemZoonita' iniciado por Kreuz Soleil, 20 Septiembre 2013.

Cargando...
  1.  
    Kreuz Soleil

    Kreuz Soleil Creador del tema Cemzoonita

    Acuario
    Muy bien, vamos a empezar esto!

    Cual es el reto, mis jovenazos? 180 PCs, distribuidas en 5 grupos. No parece dificil, verdad? bueno, las 180 PCs estan partidas en 2 edificios, simetricamente, 90 a un lado, 90 al otro, e interconectadas por routers.

    Hm... tenemos que atravezar dos routers... y aun asi mantenernos en la misma red... que vamos a usar? VLANs!

    Pero, hay un grado de incomodidad extra... todos los grupos estan dentro de la red 192.168.0.0, deben verse entre si, pero no pueden comunicarse con otros grupos, asi que tenemos que recurrir al subneteo, en este caso con VLSM (o sea que vamos a hacer bonitos y refrescantes trucos con las mascaras de subred)

    Luego... vamos a tener que configurar los routers para que hagan el enrutamiento entre ambas partes... usando RIP y Dot1Q. Los detalles tecnicos en esta parte se me hacen algo vagos para explicar, asi que solo estoy recurriendo a mi vasta y genial memoria.

    Y asi... comienzo esta aventura de 36 horas para diseñar esta red. En Packet Tracer.

    @Velli aqui estamos xD
     
    • Me gusta Me gusta x 1
  2.  
    Velli

    Velli Cemzoonita

    Géminis
  3.  
    Kreuz Soleil

    Kreuz Soleil Creador del tema Cemzoonita

    Acuario
    Se agradece que da calambre xD

    Formato basico.png

    Esta es la forma basica de la red, distribucion jerarquica para obtener puntos de elegancia, pero por que 5 switches en capa de acceso, me diran? bueno, es simple, se tiene que proyectar un crecimiento del 20%, asi que, 108 puertos por lado. Los redonditos rojos tristes, por que estan ahi? por que los puertos fast ethernet en los routers estan apagados por default, al igual que sus puertos seriales. Acabo de poner todo en su lugar, no sean criticones e.e
     
  4.  
    Kreuz Soleil

    Kreuz Soleil Creador del tema Cemzoonita

    Acuario
    Hm... y es aqui donde hay que empezar a diseñar. Dios... que horrible es diseñar...

    Las subredes son:

    Docentes 40
    Administrativos 20
    Estudiantes 100
    Investigadores 10
    Tesistas 10

    Entonces, las subredes a repartir son:

    Docentes 40 > 64
    Administrativos 20 > 32
    Estudiantes 100 > 128
    Investigadores 10 > 16
    Tesistas 10 > 16

    FSCK, 256 exactos. Entonces...

    Estudiantes 100 > 128 (192.168.0.0 a 192.168.0.127)
    Docentes 40 > 64 (192.168.0.128 a 192.168.0.191)
    Administrativos 20 > 32 (192.168.0.192 a 192.168.0.223)
    Investigadores 10 > 16 (192.168.0.224 a 192.168.0.239)
    Tesistas 10 > 16 (192.168.0.240 a 192.168.0.255)

    Un-FSCKING-believable. Que suerte que con el crecimiento parece que sigo teniendo espacio... pero en investigadores y tesistas, estan bien apretitos. 10 IPs + 2 de crecimiento + 1 de red + 1 de broadcast + 2 gateway = 16 IPs. Awesome.
     
  5.  
    Kreuz Soleil

    Kreuz Soleil Creador del tema Cemzoonita

    Acuario
    Para referencia:

    VLAN 10: Estudiantes 100 > 128 (192.168.0.0 a 192.168.0.127) Máscara: 255.255.255.128
    VLAN 20: Docentes 40 > 64 (192.168.0.128 a 192.168.0.191) Máscara: 255.255.255.192
    VLAN 30: Administrativos 20 > 32 (192.168.0.192 a 192.168.0.223) Máscara: 255.255.255.224
    VLAN 40: Investigadores 10 > 16 (192.168.0.224 a 192.168.0.239) Máscara: 255.255.255.240
    VLAN 50: Tesistas 10 > 16 (192.168.0.240 a 192.168.0.255) Máscara: 255.255.255.240
     
  6.  
    Kreuz Soleil

    Kreuz Soleil Creador del tema Cemzoonita

    Acuario
    Bueno, me sente contra la pared, por que aparentemente programe un overlapping entre las entradas fast ethernet 0/0 y 1/0 de los routers, por el hecho de que las 5 subredes tengas acceso por las 5 entradas... pero no se puede hacer sin trucos mas complicados. Asi que recurri a dispersarlos por bloques.

    Los grupos de 3 switches conectaran las subredes de Estudiantes y de Tesistas, dandome 55 + 20% = 66 puertos requeridos... tengo 69, so, profit.

    Los grupos de 2 switches conectaran las subredes de Docentes, Administrativos, e Investigadores. Aparentemente, parte de lo que se requiere es la comunicacion entre Docente y Administrativos, pero quien soy yo para preguntar por que? sus razones tienen. Compartir archivos, and all that crap. Tengo 46 puertos disponibles, y necesito 35 + 20% = 42, una vez mas, calzando bastante bien con el crecimiento.
     
  7.  
    Kreuz Soleil

    Kreuz Soleil Creador del tema Cemzoonita

    Acuario
    Creadas las VLANs, aplicadas las restricciones por puertos, rip configurado (creo), troncales configuradas... sera que acabe? no estoy seguro, pero no recuerdo que mas debo hacer...
     
  8.  
    Kreuz Soleil

    Kreuz Soleil Creador del tema Cemzoonita

    Acuario
    Y... the bane of my existence.

    Si intento hacer ping de un edificio al otro, no me lo deja hacer por sagrada vida. Tengo la impresion de que esta tomando la subinterface del router como una terminal y no como... bueno, un router. Hm... 24 horas para resolver esto.
     
  9. quisiera ayudar, pero apenas estoy viendo eso este semestre .-. .... y aun no llego al enrutamiento xD, he estado viendo por mi cuenta, pero apenas y comprendo minimamente lo que estas haciendo... asi que no podré colaborar mucho, aun así, intentaré hacerlo en el packet tracer a ver que tal me sale xD
     
  10. OHOHOHOHOHO.
    Llegaste un semestre tarde en mi vida. Llevé la materia de Redes el semestre pasado y ugh, nuestro profesor nunca, pero NUNCA abrió el Packet Tracer para ayudarnos a moverle y poner redes, submascaras, cableado y puertos. Tuve que aprenderlo en 5 minutos para hacer un proyecto final. uwu

    Es divertido cuando le entiendes, incluso, hasta repetitivo, pero bueno.
    Nice shit. :D
     
  11.  
    neo bahamut

    neo bahamut Cemzoonita

    Escorpión
    Puedes adjuntar el show run de ambos Routers :D?
     
  12.  
    Kreuz Soleil

    Kreuz Soleil Creador del tema Cemzoonita

    Acuario
    Estoy... jugando con ambos router un momento. me hice una imagen y ahora me los estoy fregando xD

    dejame ver...

    Router 1

    Building configuration...

    Current configuration : 793 bytes
    !
    version 12.4
    no service timestamps log datetime msec
    no service timestamps debug datetime msec
    no service password-encryption
    !
    hostname Router
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    spanning-tree mode pvst
    !
    !
    !
    !
    interface FastEthernet0/0
    no ip address
    duplex auto
    speed auto
    !
    interface FastEthernet0/0.10
    encapsulation dot1Q 10
    ip address 192.168.0.2 255.255.255.128
    !
    interface FastEthernet0/0.50
    encapsulation dot1Q 50
    ip address 192.168.0.242 255.255.255.240
    !
    interface FastEthernet0/0.99
    encapsulation dot1Q 99 native
    no ip address
    !
    interface FastEthernet0/1
    no ip address
    duplex auto
    speed auto
    !
    interface Serial0/1/0
    ip address 10.0.0.1 255.0.0.0
    !
    interface Vlan1
    no ip address
    shutdown
    !
    ip classless
    !
    !
    !
    !
    !
    !
    !
    line con 0
    !
    line aux 0
    !
    line vty 0 4
    login
    !
    !
    !
    end

    Router 0

    Building configuration...

    Current configuration : 793 bytes
    !
    version 12.4
    no service timestamps log datetime msec
    no service timestamps debug datetime msec
    no service password-encryption
    !
    hostname Router
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    spanning-tree mode pvst
    !
    !
    !
    !
    interface FastEthernet0/0
    no ip address
    duplex auto
    speed auto
    !
    interface FastEthernet0/0.10
    encapsulation dot1Q 10
    ip address 192.168.0.1 255.255.255.128
    !
    interface FastEthernet0/0.50
    encapsulation dot1Q 50
    ip address 192.168.0.241 255.255.255.240
    !
    interface FastEthernet0/0.99
    encapsulation dot1Q 99 native
    no ip address
    !
    interface FastEthernet0/1
    no ip address
    duplex auto
    speed auto
    !
    interface Serial0/1/0
    ip address 10.0.0.2 255.0.0.0
    !
    interface Vlan1
    no ip address
    shutdown
    !
    ip classless
    !
    !
    !
    !
    !
    !
    !
    line con 0
    !
    line aux 0
    !
    line vty 0 4
    login
    !
    !
    !
    end
     
    Última edición: 20 Septiembre 2013
  13.  
    Kreuz Soleil

    Kreuz Soleil Creador del tema Cemzoonita

    Acuario
    Lo de las IP para la vlan nativa aun no lo he hecho... tengo entendido que tengo darle IPs a las subinterfaces de los routers... pero ahora no estoy seguro si la nativa es vital, o si es redundante.
     
  14.  
    Kreuz Soleil

    Kreuz Soleil Creador del tema Cemzoonita

    Acuario
    Porca MISERIA! Donde estan mis RIP? xD

    Edit: Agregados, para 192.168.0.0 y 10.0.0.0 en ambos routers...
     
    Última edición: 20 Septiembre 2013
  15.  
    Kreuz Soleil

    Kreuz Soleil Creador del tema Cemzoonita

    Acuario
    Basicamente, lo que necesito es tener computadoras de una misma VLAN separadas por 2 routers... y no encuentro manera ni ejemplos de como hacerlo, todas usan switches, y revisando el ping, todo llega por esos switches.
     
    Última edición: 20 Septiembre 2013
  16. aun no lo resuelves? o.ó? , saliendo de clases me pongo a revisar, lastima que hoy no viene mi profesor xD, y.... mañana lo veo pero hasta las 11:30, no sé si quede en tu tiempo limite xD creo que no xp
     
  17.  
    Kreuz Soleil

    Kreuz Soleil Creador del tema Cemzoonita

    Acuario
    Nope, me quedan 17 horas y media xD
     
  18. nop xD demasiado tarde, mas tardesito que salga le sigo investigo xD
     
  19.  
    Kreuz Soleil

    Kreuz Soleil Creador del tema Cemzoonita

    Acuario
    VLAN & subnets across Routers... so troublesome...
     
  20.  
    Degote

    Degote Cemzoonita

    Leo
    Siento no poder ayudar pero esto por ahora se me escapa un poco... hace poco hemos empezado con pt y bueno mi experiencia con esto es pobre...

    Estaré al tanto del tema.
     
  21.  
    Kreuz Soleil

    Kreuz Soleil Creador del tema Cemzoonita

    Acuario
    De acuerdo a mi hermano (el informatico que encontre) lo que se propone aca es... altamente impractico. Muchas referencias online dicen que es imposible, pero otra gente dice que si se puede... al final, ya ni se. Si me dijeran "no uses Routers, pon Switchs" yo seria tan feliz...
     
  22.  
    neo bahamut

    neo bahamut Cemzoonita

    Escorpión
    Bueno, perdón por no responder temprano xD...

    Comencemos a analizar todo:

    1- El diseño tiene un déficit, lo ideal siempre es tener unos equipos que realicen la capa de distribución y conecte la etapa de Core y la capa de Acceso, en tú caso, plantearía lo siguiente:

    [​IMG]

    2- Para el esquema de direccionamiento, quiero partir del siguiente planteamiento:

    • 192.168.10.0/24 (Sede 1)
    • 192.168.20.0/24 (Sede 2)
    ¿Por qué?, el tercer octeto del direccionamiento IP me definirá la sede, por lo que todo lo que tenga 1X será de la sede 1 y 2X sede 2...esto con el fin de tener un amplio rango de direccionamiento disponible por si se desea crecer a nivel de VLAN y mantener un orden de administración correcta.

    La distribución de VLAN sería (contando que en ambas sedes se tendrán la misma cantidad de VLANs y usuarios):

    VLAN 10: Estudiantes 192.168.10.0/25
    VLAN 20: Docentes 192.168.10.128/26
    VLAN 30: Administrativos 192.168.10.192/27
    VLAN 40: Investigadores 192.168.10.224/28
    VLAN 50: Tesistas 192.168.10.240/28

    Para la sede B sería igual, pero el tercer octeto sería 20.

    3- La configuración de los Switches sería la siguiente:

    ---Ver archivo adjunto de configuración de SW de Acceso---
    ---Ver archivo adjunto de configuración de SW de Borde---

    En pocas palabras, se realizó lo siguiente:

    Para los Switches de Acceso, se crearon todas las VLANs con el comando: vlan X...posteriormente, se asignan la VLAN a cada uno de los puertos donde vamos a conectar los usuarios. El puerto Fa0/24 se configuró como puerto troncal para transmitir las VLANs.

    Para los Switches de Distribución, se configuraron todos los puertos que conectan a los switches en modo troncal, junto con el que comunica al Router Cisco.

    4- La configuración del Router comprende lo siguiente:

    • Se configuró las puertas de enlace para todas las VLANs, para cuestión de orden, se recomienda utilizar la primera IP válida del rango o la última IP válida del rango. Por cada VLAN, se configura la dirección IP en la respectiva subinterfaz. Esto se realizó en el Router 1 y Router 2
    • Para configurar el enrutamiento dinámico RIP, se activa la versión 2 y se añade en el Router 1 la subred 192.168.10.0 - 192.168.50.0 y en el router 2 la subred 192.168.20.0 - 192.168.50.0.
    • Para la conexión entre los dos seriales, se utilizó la subred 192.168.50.0/30. Y el clockrate para la conexión entre los dos Routers es 64000.
    ---Ver archivo adjunto de configuración de Router 1---
    ---Ver archivo adjunto de configuración de Router 2---

    No hay que configurarle la VLAN nativa, ya que en los Switches se la dejé por defecto en la VLAN 1, el Router por defecto utilizará la VLAN 1 como VLAN nativa.

    Por último, desde un PC en la VLAN 10 de la sede 1:

    [​IMG]

    Espero que esto te haya aclarado las dudas xD.
     

    Archivos adjuntos:

    • Me gusta Me gusta x 4
  23. jajajaja wow wow wow!! xD, todo lo que se aprende de una sola practica owo, genial!, entonces virtualmente todo está en subnets para los routers y empaquetado en la encapsulacion dot1q, pero fisicamente todo está configurado todo bajo 192.168.X0.XXX (NO porno xD).... todo lo entendí, me fuí a investigar sobre las VLAN y el RIP, ya me estaba dando una idea de como se hace, pero con lo que escribiste me fuí a ver sobre los enlaces troncales (trunk) y wow! faltaba eso xD nunca iba a funcionar sin esos enlaces xD... fascinante!... solo me queda una ultima duda!... (yo, no sé si a rupan xD)


    Router 1:

    interface FastEthernet0/0.10
    encapsulation dot1Q 10
    ip address 192.168.10.1 255.255.255.128
    !
    interface FastEthernet0/0.20
    encapsulation dot1Q 20
    ip address 192.168.10.129 255.255.255.192
    !
    interface FastEthernet0/0.30
    encapsulation dot1Q 30
    ip address 192.168.10.193 255.255.255.224
    !
    interface FastEthernet0/0.40
    encapsulation dot1Q 40
    ip address 192.168.10.225 255.255.255.240
    !
    interface FastEthernet0/0.50
    encapsulation dot1Q 50
    ip address 192.168.10.241 255.255.255.240


    Router 2:

    interface FastEthernet0/0.10
    encapsulation dot1Q 10
    ip address 192.168.20.1 255.255.255.128
    !
    interface FastEthernet0/0.20
    encapsulation dot1Q 20
    ip address 192.168.20.129 255.255.255.192
    !
    interface FastEthernet0/0.30
    encapsulation dot1Q 30
    ip address 192.168.20.193 255.255.255.224
    !
    interface FastEthernet0/0.40
    encapsulation dot1Q 40
    ip address 192.168.20.225 255.255.255.240
    !
    interface FastEthernet0/0.50
    encapsulation dot1Q 50
    ip address 192.168.20.241 255.255.255.240



    Aqui estas configurando una red con proyeccion a 255 pc's (un suponer) en cada edificio???, o el hecho de que la subnet en el tercer octeto sea 10 y 20 para cada router no afecta? D: , no tendrían que ser la misma subred? , ya que las 180 PC's que plantea Rupan en los dos edificios estan divididos en forma simetrica 90 y 90, y se plantea que los usuarios "Estudiantes" Puedan tener comunicacion y compartir............... aaaaah no... ya ya ya jajajajaja xD acabo de caer en la cuenta xDxD jajajajaja para eso es la encapsulation xD .... jajajaja olvida mi duda... y si, lo posteo con todo y correccion xp por si alguien tenía la misma duda

    la encapsulation dot1Q XX los mete en la misma subnet a los que tienen la misma encapsulacion sin importar que tengan el tercer octeto diferente... cierto? .... espero que si sea asi xD

    jajaja me gustó esta practica xD a ver cuando traen mas de esto xD

    EDIT: me estaba guiando de una practica algo parecida :P
     
    Última edición: 21 Septiembre 2013
  24.  
    Kreuz Soleil

    Kreuz Soleil Creador del tema Cemzoonita

    Acuario
    Esto esta muy bien, y te agradezco muchisimo el empeño que te tomaste en hacerlo, pero tengo unas limitaciones tecnicas horribles...

    -Todas las IP tiene que estar en 192.168.0.0, las vlans y subredes son derivados de estas.
    -Conectar una red con otra red (o una subred con otra subred) no es el problema. El problema es que hay dos componentes de la MISMA red en ambos pedazos de los 2 routers. En el grafico que pusiste, ponte que tienes que hacer un ping entre PC0 y PC5... donde uno es 192.168.0.12/25 y el otro 192.168.0.15/25. El router reacciona de manera instintiva pensando "hey, la ip que buscas esta en una red con las mismas caracteristicas que la red de donde esta viniendo el ping. No necesito cruzar el rio, de seguro se encontrara dentro de este segmento" y no pasa el ping a traves del enlace de los routers. Basicamente, lo que necesito es Broadcast del segmento A al segmento B, para las 5 subredes. Si tuviese mas ips para usar seria un gnomo feliz, pero estoy limitado, tal y como te digo, a que todo calze en 192.168.0.0.

    En este momento voy a dormir, te agradezco mucho tu esfuerzo, mañana recurrire a un truco psicologico si es que no logro resolverlo xD
     
  25.  
    Kreuz Soleil

    Kreuz Soleil Creador del tema Cemzoonita

    Acuario
    La cantidad de switches es por la dimension... 180 +20% de crecimiento... estoy pensando en hacer pedacitos las redes de 10 para convertirlas en redes 5... mascara de subred 8... 1 broadcast, 1 red, 1 gateway, 5 ips... pero me quedo sin 1 puerto para el crecimiento. Por un instante parecia tener la solucion. Pero ya encontrare algo, sino, elegancia y subterfugio, que para algo es mi arte...
     
  26. espera es cierto xD, la matemática no me anda ya jaja xD...... los switch solo dan 75 en cada edificio, cuando debería ser 90 + 20% xp
    um... seguiré buscando otro ratito D:
     
  27. no me da la red... ya me dió sueño xD..... y no se puede ejecutar
    ip route
    es cierto lo que dice rupan, los routers piensan que las maquinas estan dentro de la misma subred y no buscan "del otro lado del rio" (como bien dice rupan)... si pudieras utilizar 192.168.1.0 xD ..... pero bueh... me voy a dormir .-. ... igualmente este pequeño experimento me ayudó a comprender y aprender muchas cosas xp jajaja
     
  28.  
    Kreuz Soleil

    Kreuz Soleil Creador del tema Cemzoonita

    Acuario
    Puntos de elegancia... Cada subred sera dividida en dos subredes, como fue mencionado antes... y se obviara el crecimiento de los tesistas y los investigadores. Si se implementa transparencia entre las VLANs (algo que no me dijeron que no haga xD) puedo usar libremente las IPs libres... las pocas que quedan.

    VLAN 10: Estudiantes 50 > 64 (192.168.0.0 a 192.168.0.63) Máscara: 255.255.255.192
    VLAN 10: Estudiantes 50 > 64 (192.168.0.64 a 192.168.0.127) Máscara: 255.255.255.192

    VLAN 20: Docentes 20 > 32 (192.168.0.128 a 192.168.0.159) Máscara: 255.255.255.224
    VLAN 20: Docentes 20 > 32 (192.168.0.160 a 192.168.0.191) Máscara: 255.255.255.224

    VLAN 30: Administrativos 10 > 16 (192.168.0.192 a 192.168.0.207) Máscara: 255.255.255.240
    VLAN 30: Administrativos 10 > 16 (192.168.0.208 a 192.168.0.223) Máscara: 255.255.255.240

    VLAN 40: Investigadores 5> 8 (192.168.0.224 a 192.168.0.231) Máscara: 255.255.255.248
    VLAN 40: Investigadores 5 > 8 (192.168.0.232 a 192.168.0.239) Máscara: 255.255.255.248

    VLAN 50: Tesistas 5 > 8 (192.168.0.240 a 192.168.0.247) Máscara: 255.255.255.248
    VLAN 50: Tesistas 5 > 8 (192.168.0.248 a 192.168.0.255) Máscara: 255.255.255.248

    Se acaban mis problemas, y estoy dentro de las restricciones tecnicas.
     
  29. justo eso estaba intentando, pero me marcaba error en mascara de red xD, me decía que era inestable... pero ya no le invertí tiempo, dormí una hora jajaja xD, genial, no andaba tan mal =*-*= ...

    Edit: ya edité me perdí xD
     
    Última edición: 21 Septiembre 2013
  30.  
    neo bahamut

    neo bahamut Cemzoonita

    Escorpión
    Es técnicamente imposible que puedas redistribuir equipos dentro de la misma subred en ambos edificios, por que para eso se crearon los routers, para interconectar segmentos diferentes.

    Puedes crear todas las VLANs en el mismo edificio con el direccionamiento 192.168.0.0...pero entonces te tocaría crear unas VLANs en un edificio y las otras VLANs en otro edificio. El Router "mata" todo el Broadcast e impide que pase a través de los enlaces, o te tocaría crear rutas estáticas para decirle al router: "Busca en el Router 2, la IP 192.168.0.15/32, pero recuerda que el segmento 192.168.0.0/25 lo tengo en el Router 1", pero esto no se ve en el ambiente real xD.
    El encapsulation dot1Q lo que hace es tomar el paquete que viene con el TAG de VLAN y lo asigna a la subinterfaz que es, por eso, si viene un paquete con el tag de VLAN 10, inmediatamente lo asigna a la subinterfaz donde tenga asignada el encapsulation dot1q10 :D
     
    • Me gusta Me gusta x 1

Comparte esta página